Exchange 2016: System requirements

This tutorial is to know the requirements likely to have in the environmental setup before installing Exchange 2016.

 

Before install Exchange 2016 is installed, we suggest that you go through this topic to ensure that your network, software, hardware, clients, and other elements address the requirements for Exchange 2016. Further, ensure you understand to realize the coexistence scenarios [listed below] which are supported for Exchange 2016 and earlier versions of Exchange.

 

  1. Supported coexistence scenarios
  2. Supported hybrid deployment scenarios
  3. Network and directory servers
  4. Directory server architecture
  5. Hardware
  6. Operating system
  7. .NET Framework
  8. Supported clients

 

1. SUPPORTED COEXISTENCE SCENARIOS

 

The mentioned below table lists the scenarios where coexistence among Exchange 2016 and earlier versions of Exchange is reinforced, supported and substantiated.

 

Coexistence of Exchange 2016 with prior earlier versions of Exchange Server

 

Exchange version

Exchange company or organization coexistence

Exchange 2007 and earlier versions

Not supported

Exchange 2010

Supported via Update Rollup 11 for Exchange 2010 SP3 or at later stage on all Exchange 2010 servers in the company or enterprise, including Edge Transport servers.

Exchange 2013

Supported and reinforced with Exchange 2013 Cumulative accumulated Update 10 or later on all Exchange 2013 servers in the company, including Edge Transport servers.

Blend of Mixed Exchange 2010 and Exchange 2013 organization

Supported with the mentioned below minimum versions of Exchange:

  • Update Rollup 11 Exchange 2010 SP3 or subsequent later on all Exchange 2010 servers in the enterprise or company, including Edge Transport servers.

  • Exchange 2013 Cumulative Update 10 or subsequent later on all Exchange 2013 servers in the enterprise, including Edge Transport servers.

 

2.Supported hybrid deployment scenarios

 

Exchange 2016 supports and corroborates hybrid deployments with Office 365 tenants which have been upgraded to the current version of Office 365.

 

3.Network and directory servers

 

The mentioned below table lists the requisite requirements for the network and the directory servers in your Exchange 2016 Company or organization.

 

Network and directory server requisite requirements for Exchange 2016

 

Component

Essential Requisition

Domain controllers

All domain controllers in the forest require to be running one of the given below:

  • Windows Server 2012 R2 Standard or Datacenter
  • Windows Server 2012 Standard or Datacenter
  • Windows Server 2008 R2 Standard or Enterprise
  • Windows Server 2008 R2 Datacenter RTM or later
  • Windows Server 2008 Standard, Enterprise, or Datacenter

Active Directory forest

The Active Directory forest functionality level require to be at Windows Server 2008 or higher.

DNS namespace support

Exchange 2016 brace and supports the following given domain name system (DNS) namespaces:

  • Contiguous
  • Noncontiguous
  • Single label domains
  • Disjoint

IPv6 support

In Exchange 2016, IPv6 is reinforces and supported only when IPv4 is also installed, configured and enabled. In case Exchange 2016 is deployed in this given configuration, and the network supports IPv4 and IPv6, all Exchange servers may send data to and receive data from servers, clients, and devices which use IPv6 addresses.

 

4.DIRECTORY SERVER ARCHITECTURE

 

The usage of 64-bit Active Directory domain controllers  maximizes directory service performance for Exchange 2016.

 

Under multi-domain environments, on Windows Server 2008 domain controllers which have the Active Directory language locally set to Japanese, your servers might not receive few attributes which are stored on an object during inbound replication.

 

Installing to configure Exchange 2016 on directory servers

 

For the sake of security and performance reasons, we suggest you to install and configure Exchange 2016 only on member servers and not on Active Directory servers. But, you may not execute DCPromo on a computer running Exchange 2016. After Exchange 2016 is setup and installed, changing its function and role from a member server to a directory server, or vice versa, is not supported.

 

5.Hardware

Hardware pre-requisite requirements for Exchange 2016

Component

Pre-requisite Requirement

Processor

x64 architecture-based deployed computer with Intel processor that braces to Intel 64 architecture (formerly known as Intel EM64T)

·

AMD processor which supports the AMD64 platform

· Intel Itanium IA64 processors is not supported

Memory

Distinguishes depending on Exchange roles and functions that are installed:

· Mailbox 8GB minimum

· Edge Transport 4GB minimum

Paging file size

The page file size minimum and maximum should be set to physical RAM plus 10MB, to a maximum capacity size of 32,778MB (32GB) in case you’re using more than 32GB of RAM.

Disk space

Utmost 30 GB on the drive on which you install and configure Exchange

· An additional 500 MB of present disk space for every Unified Messaging (UM) language pack which you plan to install

· 200 MB of present disk space on the system drive

· A hard disk which stores the message queue database on with utmost 500 MB of free space.

Drive

DVD-ROM drive, local or widely network accessible

Screen resolution

1024 x 768 pixels or much higher

File format

Disk partitions formatted as file system, NTFS file systems, which is applicable to the following partitions:

· System partition

· Partitions which store Exchange binary files or files created by Exchange diagnostic logging

· Disk partitions consists of the following categories of files can be formatted as ReFS:

· Partitions consists of transaction log files

· Partitions consists of database files

· Partitions consists of content indexing files

 

6.OPERATING SYSTEM

 

The given below table lists substantially supported operating systems for Exchange 2016.

 

Note:

 

The installation of Exchange 2016 on a computer is not supported which runs in Windows Server Core mode. The computer system should be running the full installation of Windows Server. In case you wish to install Exchange 2016 on a computer which is running in Windows Server Core mode, you should convert the server to a full installation of Windows Server by executing the command

Install-WindowsFeature Server-Gui-Mgmt-Infra, Server-Gui-Shell -Restart.

 

Supported operating systems for Exchange 2016

 

Component

Pre-requisite Requirement

Mailbox and Edge Transport server functions and roles

 Windows Server 2012 R2 Standard or Datacenter

· Windows Server 2012 Standard or Datacenter

Management mechanism tools

One among the following:

·Windows Server 2012 R2 Standard edition or Datacenter
·Windows Server 2012 Standard edition or Datacenter
·Windows 10 [64-bit edition ]
·Windows 8.1 [64-bit edition ]

 

 

Substantially Supported Windows Management Framework versions for Exchange 2016

Exchange 2016 supports ONLY the version of Windows Management Framework which is develop or created in to the release of Windows which you’re installing or configuring Exchange on. Avoid installing versions of Windows Management Framework which are made duly available as stand-alone downloads on servers running Exchange.

 

7 .NET Framework

We strictly recommend you to use the latest current version of .NET Framework which is supported by the release of Exchange you’re installing.

 

Exchange version

.NET Framework 4.6.2 or later

.NET Framework 4.6.1

.NET Framework 4.5.2

.NET Framework 4.5.1

.NET Framework 4.5

Exchange 2016 CU2 or later

X1,2

 X

Exchange 2016 RTM or CU1

 X

 

a) NET Framework 4.6.1 needs post-release fixes in case you want to install it on a server running Exchange 2016 CU2.

 

b) In case you’re upgrading or updating to Exchange 2016 CU2 from Exchange 2016 RTM or Exchange 2016 CU1, we strictly recommend you to install & configure Exchange 2016 CU2 prior to .NET Framework 4.6.1 and its related post-release fixes.

 

    8.Supported clients

  • Exchange 2016 and Exchange Online confirm to support the following listed versions of Outlook:
  • Outlook 2013
  • Outlook 2016
  • Outlook 2010 with KB2965295
  • Outlook for Mac for Office 365
  • Outlook for Mac 2011

Note:

The information mentioned above gives the minimum versions needed for a client to connect to Exchange and Exchange Online. We recommend that you install and configure the latest available service packs and updates present such that your users get the best possible exposure and experience when connecting to Exchange and Exchange Online.

Outlook clients edition earlier than Outlook 2010 are not supported. Also, Email clients on Mac operating systems which require DAV, like Entourage 2008 for Mac RTM and Entourage 2004, are also not get supported.

Kristin is a content strategist at Techarex Networks. Kristin follows the B2B technology space closely and loves to write on the latest changes in technology, futuretech and fixes for day to day how to issues. Besides writing Kristin also loves music, moves and skating.

Techarex Networks provides the complete range of Hosted Exchange solutions and services, giving access to reliable, secure, messaging and collaborative enterprise-grade solutions having 99.999% uptime with unmatched SLA. Provide enterprise-level sync with Outlook Web App and mobile devices. Anywhere, anytime access using Instant Message and video calling integration.